I hate SuSE and rpm

Dans la catégorie: Geekeries — kwyxz le 28/03/03 à 15:49

Celà va faire une semaine que je bataille pour compiler OpenOffice.org sur le p610 qui est, je le rappelle, une machine à base de processeur PowerPC. La distribution utilisée est une SLES (SuSE Linux Entreprise Server) 8, je vous vois venir, non, c’est pas moi qui ai choisi. Jamais de la vie je n’aurai choisi un truc pareil. Voici pourquoi.

Le dmake de OpenOffice.org me dit :

Checking DLL ../../../unxlngppc.pro/lib/check_libmozabdrv2.so …: ERROR: /lib/libc.so.6: version `GLIBC_2.3′ not found (required by /home/kwyxz/oo_1.0.2_src/solver/641/unxlngppc.pro/lib/libnspr4.so)
dmake: Error code 1, while making ‘../../../unxlngppc.pro/lib/libmozabdrv2.so’
—* TG_SLO.MK *—

Je me dis “bon, bah on va installer une Glibc 2.3, alors”. Comme je ne comprends strictement rien aux histoires de licence, de download de packages, de droits, autour de la SLES et qu’aucun nouveau package de glibc n’est dispo sur le serveur privé d’IBM, je récupère des RPM pour SuSE non officiels. Déjà, je prends le risque de tout casser sur le système, mais bon tant pis. Sauf que :

pinux:/home/kwyxz/arch # rpm -Uvh glibc-devel-2.3.2-2.ppc.rpm
error: failed dependencies:
glibc = 2.3.2 is needed by glibc-devel-2.3.2-2
libc.so.6(GLIBC_2.3) is needed by glibc-devel-2.3.2-2

Ah oui mince, j’oubliais.

pinux:/home/kwyxz/arch # rpm -Uvh glibc-2.3.2-2.ppc.rpm
error: failed dependencies:
glibc = 2.2.5 is needed by glibc-locale-2.2.5-108
glibc = 2.2.5 is needed by glibc-devel-2.2.5-108

Rah.

pinux:/home/kwyxz/arch # rpm -e glibc-devel
error: removing these packages would break dependencies:
glibc-devel is needed by gcc-3.2-32

Euuuh… Bon bah aux grands mots.

pinux:/home/kwyxz/arch # rpm -e gcc-3.2
error: removing these packages would break dependencies:
gcc = 3.2-32 is needed by gcc-c++-3.2-32

Mais merde !

pinux:/home/kwyxz/arch # rpm -e gcc-c++-3.2-32

Ah.

pinux:/home/kwyxz/arch # rpm -e gcc-3.2

Tout va bien.

pinux:/home/kwyxz/arch # rpm -e glibc-devel
cannot remove /usr/include/sys – directory not empty
cannot remove /usr/include/rpcsvc – directory not empty
cannot remove /usr/include/net – directory not empty

On y est presque.

pinux:/home/kwyxz/arch # rpm -e glibc-locale
error: removing these packages would break dependencies:
glibc-locale is needed by susewm-3.6.0-100

Argh.

pinux:/home/kwyxz/arch # rpm -e susewm-3.6.0-100
error: removing these packages would break dependencies:
susewm is needed by susewm-kcmyast-3.6.0-100
susewm is needed by kdebase3-SLES-8-53

Ah. Et comme je ne sais pas du tout ce qu’est susewm, je fais quoi ? Je casse toute la distrib ? Bon, bah tant pis.

Je vire kdebase et tout ce qui y touche. Je vire susewm.

pinux:/home/kwyxz/arch # rpm -Uvh glibc-2.3.2-2.ppc.rpm
glibc : ##################################

Cool.

pinux:/home/kwyxz/arch # rpm -Uvh glibc-devel-2.3.2-2.ppc.rpm
Segmentation Fault
pinux:/home/kwyxz/arch #

Je veux mourir.

Aucun commentaire »

No comments yet.

Flux RSS des commentaires de ce post • Adresse de TrackBack

Laisser un commentaire

XHTML: Vous pouvez utiliser ces tags: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>